Бесплатный форум: форум поддержки
Добро пожаловать на форум поддержки сервиса Forum2x2 !

Для полноценной работы с форумом,
пожалуйста, войдите на форум под своим логином (если вы уже зарегистрированы) или же зарегистрируйтесь.


С нашей помощью вы можете создать форум,
похожий на этот!
Мы в социальных сетях

Правила форума

для обязательного прочтения!


Внимание! Важная информация для РЕГИСТРАЦИИ на форуме:

Пожалуйста, не регистрируйтесь на этом форуме с электронными адресами mail.ru, bk.ru, inbox.ru, list.ru - вам может не прийти письмо со ссылкой активации!
Вы можете воспользоваться адресами типа yandex.ru, rambler.ru, gmail.com и т.д.
Интересные решения
Быстрый переход к сервисам: j-p-g.net Видео фоторедактор Транслит

В скриптах для проигрывания музыки не работает autostart

Предыдущая тема Следующая тема Перейти вниз

В скриптах для проигрывания музыки не работает autostart

Сообщение автор borbor в Пт 19 Мар - 15:52

Мне нужно, чтобы музыка запускалась сама при открытии форума или какой-то страницы.
Перепробовал разные варианты скриптов, но результат одинаков. Музыка играет, но только после щелчка пользователя по проигрывателю.
Что можно сделать?
Привожу пример одного из скриптов:

<EMBED height=27 type="audio/mpeg mpga mp2 mp3" width=77 src=http://www.realmusic.ru/system/mplayer/mediaplayer.swf?file=http://files.realmusic.ru/files/6377/6377..mp3 border="0" autostart="true" loop="-1">

Мой форум http://710-polk.forumei.net/index.htm

borbor
Новичок

Мужчина

Сообщения : 28
Регистрация : 2010-03-17
Благодарности : 0

Без предупреждений

http://710-polk.forumei.net/forum.htm

Вернуться к началу Перейти вниз

Re: В скриптах для проигрывания музыки не работает autostart

Сообщение автор Изобретатель в Пт 19 Мар - 16:05

Попробуйте для тэста вот этот плеер. Только там вместо музыки стоит звук запускаемого лодочного мотора. Ну ссылку то если что поменяете.

Обратите внимание на нижние строчки кода плеера.

<center><embed src='http://www.fileden.com/files/2009/4/12/2401246/%D0%97%D0%B2%D1%83%D0%BA%20%D0%BF%D0%BE%D0%B4%D0%B2%D0%B5%D1%81%D0%BD%D0%BE%D0%B3%D0%BE%20%D0%BC%D0%BE%D1%82%D0%BE%D1%80%D0%B0.mp3' width=77 height=27 loop=-1 autostart=true border=0></center>

Вот еще. Этот с музыкой -

<left><embed src="http://fantasyflash.ru/music/midi/midi19.mid" loop="-1" autostart="true" border="0" height="27" width="77"></left>


У меня нормально запускается.
avatar
Изобретатель
 

Мужчина

Сообщения : 2570
Регистрация : 2009-02-26
Благодарности : 215

Без предупреждений

http://turist.tosm-boa.com/

Вернуться к началу Перейти вниз

Re: В скриптах для проигрывания музыки не работает autostart

Сообщение автор borbor в Пт 19 Мар - 17:01

У Вас мой скрипт запускается или Ваши?

Первый Ваш скрипт заставил отобразиться проигрыватель, но звука никакого, даже после попытки принудительного пуска.
Второй не только не извлёк ни звука, но и графически не отобразился.
Мой скрипт играет только по принуждению.

borbor
Новичок

Мужчина

Сообщения : 28
Регистрация : 2010-03-17
Благодарности : 0

Без предупреждений

http://710-polk.forumei.net/forum.htm

Вернуться к началу Перейти вниз

Re: В скриптах для проигрывания музыки не работает autostart

Сообщение автор Изобретатель в Пт 19 Мар - 17:33

У меня запускается мой... , но вообще я брал коды этих плееров вот - отсюда.

Попробуйте взять код оттуда же где и я. Еще - вставлять код нужно при таком виде значка - open .

Вот код еще одного плеера оттуда (там, на сайте по моей ссылке, он у вас тоже должен играть), который я взял только что -

Код:
<center><embed src='http://fantasyflash.ru/music/midi/midi1.mid' width=77 height=27 loop=-1 autostart=true border=0></center>


Может быть у вас что то не обновлено или не включено на компьютере? Попробуйте проверить.
avatar
Изобретатель
 

Мужчина

Сообщения : 2570
Регистрация : 2009-02-26
Благодарности : 215

Без предупреждений

http://turist.tosm-boa.com/

Вернуться к началу Перейти вниз

Re: В скриптах для проигрывания музыки не работает autostart

Сообщение автор borbor в Пт 19 Мар - 22:46

Возможно это произошло из-за непорядка с шаблонами. Я в них не лазил и ничего не менял.
Изначально я создал скелет форума в версии phpBB3 а затем переключился на phpBB2. Возможно переключение произошло некорректно.
Вчера я пожаловался, что всё время строки сливаются в поле сообщения. Кто-то устранил это, сейчас вот с этим бьюсь.
Ещё вопрос. Где находится упомянутый значёк. Не нашёл.
HTML у меня разрешён в настройках.
Помогите устранить!

borbor
Новичок

Мужчина

Сообщения : 28
Регистрация : 2010-03-17
Благодарности : 0

Без предупреждений

http://710-polk.forumei.net/forum.htm

Вернуться к началу Перейти вниз

Re: В скриптах для проигрывания музыки не работает autostart

Сообщение автор Изобретатель в Пт 19 Мар - 23:49

Ещё вопрос. Где находится упомянутый значёк. Не нашёл.
HTML у меня разрешён в настройках.
Помогите устранить!

Вот ( open ) объяснения на примере виджетов и их окна для вставки HTML кодов - скрины -

Обратите внимание больше на нижний скриншот -



avatar
Изобретатель
 

Мужчина

Сообщения : 2570
Регистрация : 2009-02-26
Благодарности : 215

Без предупреждений

http://turist.tosm-boa.com/

Вернуться к началу Перейти вниз

Re: В скриптах для проигрывания музыки не работает autostart

Сообщение автор Изобретатель в Сб 20 Мар - 8:36

Да, а HTML еще должен быть разрешен и в профиле у пользователя. У вас там он разрешен?
avatar
Изобретатель
 

Мужчина

Сообщения : 2570
Регистрация : 2009-02-26
Благодарности : 215

Без предупреждений

http://turist.tosm-boa.com/

Вернуться к началу Перейти вниз

Re: В скриптах для проигрывания музыки не работает autostart

Сообщение автор borbor в Сб 20 Мар - 13:37

Изобретатель пишет:Да, а HTML еще должен быть разрешен и в профиле у пользователя. У вас там он разрешен?
Не нахожу способа разрешить/отказать в профиле пользователя.

borbor
Новичок

Мужчина

Сообщения : 28
Регистрация : 2010-03-17
Благодарности : 0

Без предупреждений

http://710-polk.forumei.net/forum.htm

Вернуться к началу Перейти вниз

Re: В скриптах для проигрывания музыки не работает autostart

Сообщение автор JackaN в Сб 20 Мар - 13:41

Профиль-закладка Личные настройки-HTML всегда включен :да
avatar
JackaN
 

Мужчина

Сообщения : 1035
Возраст : 22
Регистрация : 2009-08-27
Благодарности : 166

Без предупреждений

Вернуться к началу Перейти вниз

Re: В скриптах для проигрывания музыки не работает autostart

Сообщение автор borbor в Сб 20 Мар - 20:59

Изобретатель пишет:Да, а HTML еще должен быть разрешен и в профиле у пользователя. У вас там он разрешен?
Разрешён в профиле и в общих настройках, но этот значёк нигде не появляется.
В виджетах, которые, собствено и построены по правилам HTM, и которые, в остальном нормально функционируют этого значка нет.
После слов: стандартный шаблон и полем ввода кода нет того промежутка, для значка, как в вашем примере.
Каков выход и есть ли он?

borbor
Новичок

Мужчина

Сообщения : 28
Регистрация : 2010-03-17
Благодарности : 0

Без предупреждений

http://710-polk.forumei.net/forum.htm

Вернуться к началу Перейти вниз

Предыдущая тема Следующая тема Вернуться к началу


 
Права доступа к этому форуму:
Вы не можете отвечать на сообщения